Very slow acceleration... o2 sensor? - Dodge Caliber Forums
Caliber SRT-4 Discussion If you have discussion that specifically relates to the Dodge Caliber SRT4 please put it in here.

 
Thread Tools Display Modes
#1 Old 02-15-2013, 07:30 PM
Doc_Sargent
Junior Member
Points: 17, Level: 1 Points: 17, Level: 1 Points: 17, Level: 1
Level up: 33% Level up: 33% Level up: 33%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Feb 2013
Location: Killeen, TX
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Question Very slow acceleration... o2 sensor?

I installed a MPx downpipe without a cat this morning. I drove it around for about two hours and the power difference was incredible. My engine check light came on after about 2 hours of driving. I stopped at a stop light and upon it turning green, I had no power. My car could drive, but I couldn't accelerate at all. I was a turtle. When I put my car in neutral/push in the clutch, I can rev like crazy. But if I'm in gear and I try to go, my RPMs go up so slow and I accelerate like a handicap cart in Walmart. I THINK I blew my o2 sensors... But I don't want to be buying and replacing things if I don't know for sure. Any suggestions?

-Tim
Doc_Sargent is offline  
Sponsored Links
Advertisement
 
#2 Old 03-01-2013, 02:36 PM
Stoney
Junior Member
Points: 301, Level: 6 Points: 301, Level: 6 Points: 301, Level: 6
Level up: 2% Level up: 2% Level up: 2%
Activity: 0% Activity: 0% Activity: 0%
 
Stoney's Avatar
 
Join Date: Jan 2013
Location: Crossfield Alberta Canada
Posts: 28
Thanks: 1
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
it is exactly your o2 sensors you need to have a programmer on your o2 sensors for the car to work correctly. your computer is shutting you down. they are smart my friend!! LOL


go to your local muffler shop and or shop and ask for help!



cheers!!!

2008 CSRT4
-AEM cold air
- HID kit
- G Force performance chip
- murdered out
Stoney is offline  
#3 Old 04-29-2013, 06:02 PM
Stoney
Junior Member
Points: 301, Level: 6 Points: 301, Level: 6 Points: 301, Level: 6
Level up: 2% Level up: 2% Level up: 2%
Activity: 0% Activity: 0% Activity: 0%
 
Stoney's Avatar
 
Join Date: Jan 2013
Location: Crossfield Alberta Canada
Posts: 28
Thanks: 1
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I literally just ran into this problem! My car does the same thing but with my new blow off valve, I had to get my code erased with a programmer. And now it works fine.
Stoney is offline  
Sponsored Links
Advertisement
 
Reply

  Dodge Caliber Forums > Dodge Caliber Discussion > Caliber SRT-4 Discussion


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome