Why does my car run like crap ? - Dodge Caliber Forums
Dodge Caliber Dodge Caliber Forum

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   Dodge Caliber Forums > Dodge Caliber Discussion > Caliber SRT-4 Discussion

Caliber SRT-4 Discussion If you have discussion that specifically relates to the Dodge Caliber SRT4 please put it in here.

CaliberForums.com is the premier Dodge Caliber Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 12-29-2008, 08:15 AM
04srt4black's Avatar
04srt4black 04srt4black is offline
Senior Member
Points: 5,944, Level: 49 Points: 5,944, Level: 49 Points: 5,944, Level: 49
Level up: 97% Level up: 97% Level up: 97%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: May 2008
Posts: 687
iTrader: (3)
Thanks: 193
Thanked 241 Times in 172 Posts
Why does my car run like crap ?

Like the title states . With all the mods in my signature i would think this car would pull better than it does . I got beat by a 04 nsrt with full exhaust , wga and a cai . And when i say beat it was by like 4 cars and from a 60mph roll !

My a/f's are 10.2-10.4 in 3rd and 4th WOT , in 1st and 2nd they are 10.0 flat . My throttle according to my scan gauge is at 88% ? Is that about right ?

Im pushing 14psi through the agp wga and holding it , but the wga only has about 5 threads left showing .

Is there something im missing with this car ? IE would spark plug gap cause that ? Stage 1 pulling timing ?

I know for sure i dont have any boost leaks as i just tightened every bolt up , changed the throttle body , intake manifold gasket , new fmic ,etc.

Any suggestions/ help is VERY much appreciated .
__________________
Sigs by GooberMT

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 12-29-2008, 08:31 AM
tomzeek's Avatar
tomzeek tomzeek is offline
Senior Member
Points: 3,321, Level: 35 Points: 3,321, Level: 35 Points: 3,321, Level: 35
Level up: 81% Level up: 81% Level up: 81%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2008
Posts: 431
iTrader: (0)
Thanks: 4
Thanked 74 Times in 52 Posts
Re: Why does my car run like crap ?

hhhm somthing is not right. i got my WGA in and i have about 3/4 of the threaded part of the rod left. i am holding 15 psi all the way to redlind. the throttle wont open past 87-88% like the srt guys said. its a misleading number. thats full open have no fear. you arent the first to have problems like this. make sure you have everything right with your vaccum setup. the green and black line are both disconnected and the WGA goes back to the Y off the turbo. when looking at the car push the gate on the turbo to the drivers side. adjust the rod arm about 1/8th inch short of the peg. pull the arm over the peg to have some "preload" i guess you would call it. that gave me an instant 12psi. install the clip and you are good. it sounds like you goofed your WGA rodarm install. pull he heat shield off and start the rod arm over just like i said and you should see great results. i have ran my friends CSRT4 a few times and yes i have gotten faster way faster. so you should in theory beat that neon. but keep in mind too that these things arent the best off a launch they love to bog then spin like hell.. traction is a big issue. race that neon from 40-100 and see who wins. if you lose something is wrong. BTW my a/f ratios are in the 11s too at redlind WOT.
__________________
my new other car!!!!!!

60,000 lbs thrust+? check
top speed--cant tell you
stealth? check
faster than your ride? check
vectored? check
picky beotch? check
destroy a mazda? literally

Last edited by tomzeek; 12-29-2008 at 09:17 AM.
Reply With Quote
The Following User Says Thank You to tomzeek For This Useful Post:
xtreme2424 (05-12-2010)
  #3  
Old 12-29-2008, 08:37 AM
tomzeek's Avatar
tomzeek tomzeek is offline
Senior Member
Points: 3,321, Level: 35 Points: 3,321, Level: 35 Points: 3,321, Level: 35
Level up: 81% Level up: 81% Level up: 81%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2008
Posts: 431
iTrader: (0)
Thanks: 4
Thanked 74 Times in 52 Posts
Re: Why does my car run like crap ?

btw dubs dont help in the acceleration department. slow you down a little actually. more rolling mass. and bigger rims also changes gear ratios. oh yeah if the neon just has a WGA it wasnt stock. it would have to have a different pcm than the stock one or he wouldnt be able to boost very high. good chance he was lying to you man. wga says he wasnt running the stock 10-12 lbs of a stock neon. a stage three or equivilant neon we still cant beat thats life with our mods. you want to beat him talk to realtune

Last edited by tomzeek; 12-29-2008 at 08:40 AM.
Reply With Quote
  #4  
Old 12-29-2008, 08:57 AM
04srt4black's Avatar
04srt4black 04srt4black is offline
Senior Member
Points: 5,944, Level: 49 Points: 5,944, Level: 49 Points: 5,944, Level: 49
Level up: 97% Level up: 97% Level up: 97%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: May 2008
Posts: 687
iTrader: (3)
Thanks: 193
Thanked 241 Times in 172 Posts
Re: Why does my car run like crap ?

^Yea the neon has a wga , hardpipes , 3" o2 housing , 3" turboback MPX exhaust and a agp cai . I installed it all so i know he isnt lying , but he is pushing 18psi to redline in 3rd and holding . His car was always like a factory freak tho .

You said to "T" intot he black line off the turbo ? I just unhooked the blackline from the turbo and put a line from the turbo to the wga directly i did NOT "T" into anything . Maybe thats my problem , hmmmmm . Not reading instructions may have ownd me .

It just dont feel fast at all tho , lol . Altho i have never rode in a stock csrt so idk .

Thanks for the help man !

edit The rims only weigh an extra 4 pounds a peice compared to the stock srt wheels (which i wish i had the money to buy some) , But yes i hate the 20's .
Reply With Quote
  #5  
Old 12-29-2008, 09:24 AM
tomzeek's Avatar
tomzeek tomzeek is offline
Senior Member
Points: 3,321, Level: 35 Points: 3,321, Level: 35 Points: 3,321, Level: 35
Level up: 81% Level up: 81% Level up: 81%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2008
Posts: 431
iTrader: (0)
Thanks: 4
Thanked 74 Times in 52 Posts
Re: Why does my car run like crap ?

yeah take the green line off the old WGA. follow the black line from the same solenoid the green one was on. it will run to a Y connector on the turbo inlet. the bottom line on the Y goes back to the other solenoid. leave that hooked up. disconnect the top one that runs to the same solenoid as the green line. run the new WGA off the empty port on the y thats what i did and she works fine
Reply With Quote
  #6  
Old 12-29-2008, 10:05 AM
tomzeek's Avatar
tomzeek tomzeek is offline
Senior Member
Points: 3,321, Level: 35 Points: 3,321, Level: 35 Points: 3,321, Level: 35
Level up: 81% Level up: 81% Level up: 81%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2008
Posts: 431
iTrader: (0)
Thanks: 4
Thanked 74 Times in 52 Posts
Re: Why does my car run like crap ?

there is a great how to in the how to section thats where i got my info
Reply With Quote
  #7  
Old 12-29-2008, 10:13 AM
04srt4black's Avatar
04srt4black 04srt4black is offline
Senior Member
Points: 5,944, Level: 49 Points: 5,944, Level: 49 Points: 5,944, Level: 49
Level up: 97% Level up: 97% Level up: 97%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: May 2008
Posts: 687
iTrader: (3)
Thanks: 193
Thanked 241 Times in 172 Posts
Re: Why does my car run like crap ?

Im just hoping the wga is what my problem is , if not i will have to dig a little bit deeper in the well .
Reply With Quote
  #8  
Old 12-29-2008, 10:45 AM
tomzeek's Avatar
tomzeek tomzeek is offline
Senior Member
Points: 3,321, Level: 35 Points: 3,321, Level: 35 Points: 3,321, Level: 35
Level up: 81% Level up: 81% Level up: 81%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2008
Posts: 431
iTrader: (0)
Thanks: 4
Thanked 74 Times in 52 Posts
Re: Why does my car run like crap ?

yeah i dont see how you only 4 threads left and are only at 14. its cranked on there tight verify your vaccum lines and then adjust preload like i said and i hope things turn out. my car runs hard man way faster than stock
Reply With Quote
  #9  
Old 12-29-2008, 11:03 AM
icemanthrilla's Avatar
icemanthrilla icemanthrilla is offline
Senior Member
Points: 28,060, Level: 98 Points: 28,060, Level: 98 Points: 28,060, Level: 98
Level up: 72% Level up: 72% Level up: 72%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: May 2008
Posts: 4,921
iTrader: (6)
Thanks: 2,627
Thanked 1,220 Times in 907 Posts
Re: Why does my car run like crap ?

my car definitely feels alot faster with stage 1, however i am not agp wastegated so maybe its just your setup. follow what tom zeek is telling u im sure it will help. Im sure the pcm is ****ing with your timing n stuff with the wastegate.

report back when u mess with it hope it helps u out.
__________________
08 Dodge Caliber srt4 group2

REALTUNE sticker!! lol
MOPAR stage 1-blow off plate-sway bars
AGP fmic-intake
MPx black headlights-strutbar-shorty ant
EIBACH drop springs
MAXXFAB downpipe w/cat
MSR 093's 20 x 8.5 in 245/35 rubber
KICKER 6x9's
TINT new dd!
Reply With Quote
  #10  
Old 12-29-2008, 11:07 AM
04srt4black's Avatar
04srt4black 04srt4black is offline
Senior Member
Points: 5,944, Level: 49 Points: 5,944, Level: 49 Points: 5,944, Level: 49
Level up: 97% Level up: 97% Level up: 97%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: May 2008
Posts: 687
iTrader: (3)
Thanks: 193
Thanked 241 Times in 172 Posts
Re: Why does my car run like crap ?

Yea i dont know if i will have time this evening or not . I got my bumper off and my headlights torn apart for my retrofit . I will try it tho , seems very logical .

Thanks again!
Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Dodge Caliber Forums > Dodge Caliber Discussion > Caliber SRT-4 Discussion


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Holy crap! 7k off 2008 Caliber Srt4s! Aaron@Realtune Realtune Performance 107 02-25-2009 10:26 AM
Midnight Run... Roo California 8 12-30-2008 05:29 AM
Fawkin' five digit crap... GreaseMonkey Caliber SRT-4 Discussion 11 08-05-2008 09:23 AM
Chevy HHR SS - looks like crap, but "gets it" srt4evah General Caliber Discussion 12 12-19-2007 04:27 AM
Oh Crap.... Need Help ASAP! Devsforev Problems / Dealer Service 17 05-22-2007 02:45 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 07:33 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
© AutoGuide