Dodge Caliber Forums - View Single Post - 2007 Caliber No-Start
View Single Post
post #6 of Old 04-23-2019, 06:16 PM
CNYguy
Junior Member
Points: 53, Level: 1 Points: 53, Level: 1 Points: 53, Level: 1
Level up: 6% Level up: 6% Level up: 6%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2019
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
// update for the people who may need it;

I was able to fix the car...and it was NOT the oil sensor. as the reader told me it was p0522..
ODB2 readers have failed me 100% of the time so far with this car. ..and it's agitating.
---
I rewired the relay switch box found behind the bumper driver side. ..a few wires were corroded.
After that, still no start but the engine would try to turn over instead of tell the wipers to move. SUCH BAD ELECTRICAL ENGINEERING!!!
----
so I check all sensors I could reach by unplugging them and plugging them back in. I do this again later, with trying to restart with each one removed.
---
I still had the p0522 problem reported. I was cursing DODGE.
---
I removed the fuel line from the bar. ..and put it back in place. That actually helped for some stupid reason but it was only part of the situation.
---
Here's what I assumed;
The car shorted due to the stupid relay switch box corrosion problem. That caused the oil sensor to be flagged by computer... getting to that sensor is a serious ****** PAIN! ..so I was trying to avoid that process especially because the car wouldn't start to drive it onto ramps for easy access. Since the car wouldn't start, it was obvi not the sensor. Stupid stupid stupid stuff. ..poking at chances to win here.
--
I assumed the sensor had 1 of two problems: 1- gunk *OR* 2- electrical stupidity reset issues.
So I went to handle both in 1 shot...mainly because I don't have a $10k computer to help me find the technical data required..I only have the gimmick ODB2 reader... which feels more like a scam than anything with this Dodge.
--
So, I tried black magic;
I jacked the car up, and swiftly dropped in the style of roll-off-the-jack ...3 times...it may sound stupid, but it's not...it's very very logical for oil displacement.
After that,,, the fecking car started. THE FECKING CAR STARTED!!!!! ...

Now there is no P0522 error after driving for sometime... and yes I was careful to listen to the engine...etc.
------------------
I will never buy another dodge... not only is the ODB2 situation of a 100% failure to provide correct data. .. but that stupid relay switch box and the corrosion of the wiring caused the issue..and the car REFUSED to allow me to fix it with normal measures.
After researching this subject and finding that Mechanics spend hours and sometimes days trying to solve this... I was pissed... it's old and there's no way spending more than the car for someone to fiddle until success would make any sense.
---- So I fiddled..with logic, while imagining that Dodge must hire college grads for bean counting that extra 10k.
---
I had to do black magic to fix this black magic car.
---BYE BYE DODGE!
----------------------
///////DISCLAIMER:
////////If you try anything in this post, you do so at your own risk.
CNYguy is offline  
 
 
For the best viewing experience please update your browser to Google Chrome