Dodge Caliber Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi there!

I recently bought a 2007 Caliber that had a few issues, but I've been working through them slowly but surely. I took it to a mechanic friend and he said the ac blend door actuator was bad.. But then the story changed to the cable that connects from the vent control knob to the mystery wheel of whiteness.

However, after waiting 2 weeks for an estimate on repair, I have decided to move on. I normally do mechanic work myself, but he's a good guy and opened up a shop recently so I was hopeful it would work out well. Nope.

The vent control knob (floor, defrost, etc.) has a cable that leads to a white wheel that rotates to change vents. Previously, I couldn't use the knob to change vents at all. It was stuck. I found out the cable was disconnected on both ends (how?). After reattaching the cable on both ends, I cannot move it to defrost (far right). It simply will not turn that far. I found a thread on here that was helpful to an extent. The person found out it was a hose that was in the way blocking it. However, this is not my issue. I believe I found the issue though.

The white wheel has a center screw, that is all that holds it on. It has channels that 3 different metal rods slide into to control the 3 different controls that all control the appropriate vents. It's quite complicated trying to memorize which assortment of these things needs to move to activate which vent. However, I believe one of these rods was not in place properly, preventing it from being able to rotate as far as it needed to to be able to activate defrost. After taking it apart, I can get it put back together, but it simply can't turn far enough with the cable attached. If I disconnect the cable, it will turn.

I am curious if perhaps someone before me tried fixing this and put it back on the wrong way and I am now imitating their mistake thinking it was on properly before. Can anyone give input on which rod goes into which channel and the best way to get them all into the appropriate channels with only being able to work with 1 hand in there?

Forgive me, I do not have pictures. I was working on this until dark and finally decided I would post on here to see if someone could help.

If anyone can provide what I have asked or even any other ideas that might be the issue, I would be greatly appreciative. Thank you in advance!
 

·
Registered
Joined
·
1 Posts
Greeting Fantrum, your post came up in a random google search I did for having a similar issue so I actually just joined this fourm just to comment. My issue is that my cable from the knob to the blend door actuator (the white thing or black one for the temperature control) got bent and has a kink it and that's what prevent me from turning my knob to defrost. Maybe you have the same issue?
 

·
Registered
Joined
·
1 Posts
Fantrum and Lough Down Black Beard i actually just joined the forum to research this same problem i'm having in my 07 SXT. I have a couple of questions to both of you is (1) Is there a YouTube video that either of you watched as to how to disassemble to get to these rods and cable? Or (2) can either of you tell me what all i have to remove to access these rods and cable. TYIA
 
1 - 3 of 3 Posts
Top