Dodge Caliber Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hey y’all, i have a 2010 mainstreet caliber with 171,000 miles on it, back in the winter we had a deep freeze and my car started acting up, i scanned the computer and got codes p2110& p2112, i erased the codes thinking that when issue showed again it would display the codes again, only trouble is its still doing it and the codes never returned.

issues are as follows,
It starts and drives fine, but while driving there is an occasional i dont know what to call it, like a missfire or stall, the acceleration just stops for a half a second to a second and then comes right back to normal, and it happens repeatedly, usually when the engine is pulling a hill or reving up, im at a loss to explain this, thinking of just replacing the throttle body but unsure if its the cause.

also, when engine is cold and you accelerate it sometimes heditates and wants to jump,kind of, i am not a mechanic, so im not sure if im giving a good explanation, but Its the best i got.
Has anyone experienced anything similar? If so, how did you correct it???

id appreciate any and all help…. Please??

James
 

·
Registered
Joined
·
2 Posts
I had the same issue just last week.
Took it to my mechanic and he found it was the throttle body sensor, he put a new throttle body in and it runs perfect.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
So update, it was a throttle body issue, ordered an aftermarket body from ebay for 40 bucks changed it out and has been running like a champ every since
 
1 - 3 of 3 Posts
Top