Dodge Caliber Forums banner

21 - 40 of 52 Posts

·
Registered
Joined
·
1,583 Posts
Discussion Starter #21
with your scan gauge are you able to reset the problem and go on your merry way or is it just come and go?
 

·
Registered
Joined
·
177 Posts
that indeed sounds like an ETC issue. i would hook up to a Starscan tool and recalibrate your throttle.
 

·
Registered
Joined
·
4,479 Posts
you know, thats a very good point

have you tried to recalibrate the throttle by the slowly pushing the pedal trick in thing?

i know it probably wouldnt do anything, but couldnt hurt to try
 

·
Registered
Joined
·
1,583 Posts
Discussion Starter #24
Yeah I gave the Pedal Dance and chance, and it is a no go. I just called my Local dodge, and they said 79.95 plus tax for a diagnostic, since I am no longer under warranty. At least then, I could find out what is wrong.

Lets just pray and hope the dealership does not come to me with an outrageous claim...
 

·
Registered
Joined
·
1,583 Posts
Discussion Starter #25 (Edited)
Car is still sitting at Dodge. I am about to call them to see what is going on.

EDIT: Just called Dodge, and they said, they have been on it for about 2 hours, and are unsure of what is going on. They said they will call me when they figure it out.

What a way to make me worried...
 

·
Registered
Joined
·
4,479 Posts
Yeah I gave the Pedal Dance and chance, and it is a no go. I just called my Local dodge, and they said 79.95 plus tax for a diagnostic, since I am no longer under warranty. At least then, I could find out what is wrong.

Lets just pray and hope the dealership does not come to me with an outrageous claim...
Car is still sitting at Dodge. I am about to call them to see what is going on.

EDIT: Just called Dodge, and they said, they have been on it for about 2 hours, and are unsure of what is going on. They said they will call me when they figure it out.

What a way to make me worried...

Only 79.99 for a diagnostic charge? When i put my srt rims on, and the tmps light started flashing(due to a bad sensor) i called them before i knew what the problem was, and asked if it would be something thats covered under warranty, because they are technically factory rims.

They told me that if it is the car causing the fault, then it would be covered, but if it was a sensor, it would be a 110 dollar diag. fee.

I told them(literally) to eat **** and id figure it out on my own.

Obviously, you are in a bit of a different position, but still pisses me off that your dealer is cheaper :rofl:

Anywho, keep up updated man, i want to know whats going on with the car:beerchug:
 

·
Registered
Joined
·
1,583 Posts
Discussion Starter #27 (Edited)
Well, I just got the car back, and the car seems completely fine!

I am going to type what the dealership service paper says...

MELLOY DODGE SERVICE said:
"CUST STATES ETC LITE IS ON AND TRAC LITE IS ON AND VECH
HAS NO POWER
ROADTESTED VECH. PERFORMED DIAG TEST WITH
STARSCAN FOUND THROTTLE BODY STICKING/BINDING

CUSTOMER REQUESTS WE CLEAN THE THROTTLE BODY
RECURRING MAINTENANCE
WE CLEANED THE THROTTLE BODY"
So needless to say, they said there was major binding and there was a lot of buildup in the throttle body. Carbon and Oil based sludge. I am more than guessing it is due to the K&N Air Filter. I am thinking of going back to stock filter, and waiting until I get a real CAI or something.

So for those of you who have this problem happen, give your Throttle body a good cleaning and hopefully that cures your problem!

Gabriel
 

·
Registered
Joined
·
4,479 Posts
Its funny, the only time i had the problem with the idle dropping was with my k&n filter on. When i took it off to clean it, and put the stock airbox back, my idle was fine. After i cleaned the filter and put it back on, it kept getting worse, so i took it off..

Good to know man...
 

·
Registered
Joined
·
730 Posts
Well, I just got the car back, and the car seems completely fine!

I am going to type what the dealership service paper says...



So needless to say, they said there was major binding and there was a lot of buildup in the throttle body. Carbon and Oil based sludge. I am more than guessing it is due to the K&N Air Filter. I am thinking of going back to stock filter, and waiting until I get a real CAI or something.

So for those of you who have this problem happen, give your Throttle body a good cleaning and hopefully that cures your problem!

Gabriel
Think about what you just typed from the service paper....

1. How does oil and carbon get into the throttle body?
2. Are you driving through an oil sludge field everyday on the way to work?
3. Did you see oil deposits on the K&N Filter?


1. You should have answered PCV System... Positive Crankcase Ventilation.
2. You should have answered NO.
3. You should have answered NO.
 
  • Like
Reactions: Sky

·
Registered
Joined
·
553 Posts
"You should have answered PCV System"

Exactly.
 

·
Registered
Joined
·
1,583 Posts
Discussion Starter #31
Well the problem has returned and the car is doing the same thing. Seems Dodge, didnt fix a damn thing. I haven't the money or time to **** with this thing anymore. Everyday this car comes with a new problem, and frankly I am tired of it.
 

·
Registered
Joined
·
1,955 Posts
Well the problem has returned and the car is doing the same thing. Seems Dodge, didnt fix a damn thing. I haven't the money or time to **** with this thing anymore. Everyday this car comes with a new problem, and frankly I am tired of it.
Not to sound like an arse or anything, but technically, it's the same problem :jester:
 

·
Registered
Joined
·
461 Posts
I'm going to go out on a limb here and say that if your throttle body was really that dirty then It might have striped the plastic gears out of the throttle body servo....
 

·
Registered
Joined
·
4,479 Posts
damn again?
 

·
Registered
Joined
·
730 Posts
Well the problem has returned and the car is doing the same thing. Seems Dodge, didnt fix a damn thing. I haven't the money or time to **** with this thing anymore. Everyday this car comes with a new problem, and frankly I am tired of it.
Then take it back in to the same Dealer and tell them you don't want it back until it's fixed.
 

·
Registered
Joined
·
1,583 Posts
Discussion Starter #36
Well we dropped the CSRT4 off this morning and it turns out the Throttle Body has failed and they are going to charge me 100 bucks to replace the unit, and get it installed.

Hopefully this takes care of everything, but i wont see my car until late tomorrow or early friday.
 

·
Registered
Joined
·
1,583 Posts
Discussion Starter #37
Just got another call from dodge and they managed to get the TB in stock, and they installed it, just to find out that the PCM is fried.

They are covering the PCM for me, but i have to wait until next week. They said it was an 800 pcm, and i told them to get the S1 for cheaper for me, and the guy said it has to be stock in order to replace it.
 

·
Premium Member
Joined
·
29,879 Posts
Just got another call from dodge and they managed to get the TB in stock, and they installed it, just to find out that the PCM is fried.

They are covering the PCM for me, but i have to wait until next week. They said it was an 800 pcm, and i told them to get the S1 for cheaper for me, and the guy said it has to be stock in order to replace it.
WOW.

They are giving you a new pcm out of warranty? Thats great for you!
 

·
Registered
Joined
·
1,583 Posts
Discussion Starter #39
i honestly think these clowns fried the pcm, as i just do not see a throttle body frying a pcm. but whatever, as long as they are paying for it.
 

·
Premium Member
Joined
·
29,879 Posts
i honestly think these clowns fried the pcm, as i just do not see a throttle body frying a pcm. but whatever, as long as they are paying for it.
maybe thats why they are "warrantying" it for you?
 
21 - 40 of 52 Posts
Top