Dodge Caliber Forums banner

1 - 20 of 30 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter · #1 ·
Well last night I was heading out to do some shopping and about 6 miles from home bells go off and the check engine light goes on. A few seconds later the engine shuts off. So I pull over and get out the manual to see what it says. Of course it does not tell you much since this light covers many minor to serious issues. So I try to start it up and get home and it does start , sputter , cough then run. On the way home I had zero pickup and basically could not go over 30 mph, since the trans or engine was acting weird.

This is great, 2500 miles and some sort of pain in the ass issue. This is my only car and I live alone, so it should be fun trying to get to work and this into service on Monday, not too happy with the Caliber now.

Seems to have a lot of issues when you look on this forum and others.

Flaps,
 

·
Registered
Joined
·
81 Posts
Man I hope its minor...Water in gas or something cause from what I've read, this Trans/engine combo sounds like it may bite us. What exactly was it doing after you got it started and moving again? sputtering more? jerking? what?
 

·
Premium Member
Joined
·
439 Posts
Sounds like you were running in limp mode when you restarted, which is your car's way of protecting itself from further damage. In some circumstances, the computers will reset after a few "good start" cycles.. hopefully this is the case for you and I wish you luck for a speedy fix if not.

As for the comment
Seems to have a lot of issues when you look on this forum and others
... remember that cars are mechanical and mechanical things do have failures, always have. What we haven't always had is internet car forums, which are ideal place to air isssues and exchange and research information. It may seem like there are a lot of problems, when in reality what has changed is your ability to 'hear' about those problems. In the past you would have to hang out at your service department to hear these kinds of conversations... long live car forums!! :D
 

·
Registered
Joined
·
143 Posts
heh this sounds kinda like what I'm going through.. made a right turn yesterday and the whole car shut off on me. No dings or error codes to speak of though.. also since then it feels like I have lost power in the mid rpm ranges.
 
  • Like
Reactions: SRT4SMACK

·
Premium Member
Joined
·
2,514 Posts
Could be something as simple as an O2 sensor, had that happen to my car before....not saying what it is, but maybe an idea....

Take it to the dealer on Monday (if you can) and get it checked out, warranties are your friend!
 

·
Registered
Joined
·
74 Posts
Discussion Starter · #6 ·
Xtreme Thunder said:
Could be something as simple as an O2 sensor, had that happen to my car before....not saying what it is, but maybe an idea....

Take it to the dealer on Monday (if you can) and get it checked out, warranties are your friend!
Just a pain in the butt for such a new car to have this problem, my last three cars went 50,000 miles each before any kind of issues and those were maintenance kinds of things anyway.

I get the feeling they did not test this car enough before release, but maybe I am just jumping the gun.

Getting it serviced is a pain in the butt too, since the dealer is 29 miles one way, then I need to get to work, then hopefully they fix it in a day, which does not seem the norm on these cars, so then I gotta get from work and back until they get it fixed, seems crazy on a 39 day old car. I only have the basic warranty, not extra coverage so I doubt they will offer a loaner car.

Lets hope for the best on the issue.

Flaps
 

·
Registered
Joined
·
131 Posts
Hmm that really stinks. Only problem I have had is the battery light coming on then when i did a reboot it went off. Hopefully just a gas issue or somethin.
 

·
Registered
Joined
·
102 Posts
I'm not sure, but it almost sounds like what happened to me when I had a timing belt tensioner fail. My car was running smooth, then all of a sudden, it started sputtering terribly, making sounds similar to that of a lawn mower. I didn't get an engine light, ironically enough. I'm not sure if these engines have chains or belts for timing, but it's just a thought as to a possible dianosis. It always drove me absolutely mad when I was younger and didn't know what problems caused different symptoms. My escort was retired at almost 153,000 miles, 70,000 of which came from me. Let's just say I learned A LOT about what different problems come from!!! LOL! Good ole Ford! Nah, I love the old girl, and I'm gonna hang onto her for some "experiments" down the road!! Good luck with everything tomorrow! Hopefully it's something easy and painless.;)
 

·
Registered
Joined
·
59 Posts
Flaps -- if you want to take a quick look at what the engine code is, there is a way to hold in the odometer "reset" button and cycle the key (It was posted on one of these forums somewhere, not sure where....). I think it was -- hold the reset button on and key on, then off 3 times or something, finally leaving the key "on". The odometer will display the P-code that set (i.e. error code). Let us know what the dealer comes up with, there's lots of curious (and syumpatheic) listers wondering...
 

·
Registered
Joined
·
18 Posts
its a shame but you must understand it just came out, most likely there will be problems. best of luck man, i feel your pain. i just hope the srt-4 version doesnt bomb out on us and have a lot of problems :(
 

·
Registered
Joined
·
1,734 Posts
srt4ownz said:
i just hope the srt-4 version doesnt bomb out on us and have a lot of problems :(
Ya, there are starting to be more an more of these things showing up as more and more members recieve their cars. I don't recall a first year production car not having some sort of rattle or sqeak that people would talk about however ^^^ is more serious and i hope that it is an isolated incident, that they fix quickly for our friend.

My guess is (1) MAF (mas air flow sensor) for somereason failed and the engine goes into safety mode or (2) if you have an auto the tranny could trip the computer into safe mode if there is a problem with the temp/coolant levels, shifting etc.
 

·
Registered
Joined
·
74 Posts
Discussion Starter · #13 ·
Well the dealer just called and it needs a part that takes 3 days to get in, so I am without vehicle for 3 or more days. Some MAF Sensor, why do these things not hold up????

I gotta say I really like the car but the reliability and issues are too many, I will never buy another new car that is in its 1st model year. Too many BS issues that are anoying to say the least.

I sure wish I had my Freelander back, horrible revues on that baby but I never ever had an issue, and if I did they always fixed it in one day and there was never and issue with a loaner.

Flaps
 

·
Registered
Joined
·
81 Posts
My guess is (1) MAF (mas air flow sensor) for somereason failed and the engine goes into safety mode or (2) if you have an auto the tranny could trip the computer into safe mode if there is a problem with the temp/coolant levels, shifting etc.
Wow, nice one....Give me your phone # for emergencies;)
 

·
Registered
Joined
·
59 Posts
Um, the caliber doesn't have a MAF sensor -- it's speed density, like all the other DCX products (MAP sensor, & RPM are used to calculate airflow). I'm curious what's really gone wrong here. MAP sensor, some ETC safety thing, failed muffler bearing....

(Note for those of you playing along at home -- MAF = Mass Air Flow, MAP = Manifold Absolute Pressure)
 

·
Registered
Joined
·
131 Posts
Tito said:
Um, the caliber doesn't have a MAF sensor -- it's speed density, like all the other DCX products (MAP sensor, & RPM are used to calculate airflow). I'm curious what's really gone wrong here. MAP sensor, some ETC safety thing, failed muffler bearing....

(Note for those of you playing along at home -- MAF = Mass Air Flow, MAP = Manifold Absolute Pressure)

I thought MAP was something my GPS uses?
 
  • Like
Reactions: SRT4SMACK

·
Registered
Joined
·
506 Posts
yea that would make sense to me... MAP Majorly Assed Piece
 
  • Like
Reactions: SRT4SMACK

·
Registered
Joined
·
74 Posts
Discussion Starter · #19 ·
mudstone said:
yea that would make sense to me... MAP Majorly Assed Piece
Map Maf it was one of those, the weird thing is they say the part is being overnighted in but will not be here until Wednesday???? Overnight = 3 days?

I aksed about this and they stuck to there story, good news is if I can get there somehow in the AM they will give me a rental/loaner which makes things easier for now.

Flaps
 

·
Registered
Joined
·
74 Posts
Discussion Starter · #20 ·
So today the dealer gives me a loaner because it will be at least 3 more days on the repair, pretty poor planing on parts for this vehicle. I know its new but geez, its been around for 4 plus months so they should have reasonable access to parts I would think.

Anyway the loaner is a PT Cruiser , Brand New. I drove it to work, and not to slam PT lovers, I would not ever own one of these, It is noisier that the Caliber, Auto is not where near as smooth as the CVT, Pickup is the same, Ride is not as good, not even close and to my eyeball there is less room inside, at least it looks like less room, especially useable room behind the back seat.

One last thing the Door panels are no nicer in fact the dash and door panels and emormous steering wheel all look lousy to me. Why do people like this car?

Flaps
 
1 - 20 of 30 Posts
Top