Dodge Caliber Forums banner
1 - 20 of 20 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter · #1 ·
Just heard from dodge and they have to Replace my transmission and have to send it back to Diamer Chrysler so they can diagnose the problem. My baby only has 5000 miles on it :( Stinks...so does the loaner they gave me...I dont smoke and it reeks of Cigarettes, is an 04 Neon, has dents on it and 39000 miles...I WANT MY BABY BACK...hope nobody else has this problem...oh well...loaner-beats walking ;)
 

·
Registered
Joined
·
256 Posts
Crappy... At least they will replace it rather than repair it. :)
 

·
Registered
Joined
·
1,985 Posts
From what i hear the CVTs are non serviceable.
 

·
Registered
Joined
·
256 Posts
Fingernipp said:
From what i hear the CVTs are non serviceable.
I was told that too by the dealer. He said the engine too. (I guess if it anything more than the real simple stuff)
 

·
Registered
Joined
·
689 Posts
Just so you know, you can ask for another loaner if another one comes available, you are not stuck with the car they gave you, if they have another one available. Sorry to hear about your transmission problems.
 

·
Registered
Joined
·
197 Posts
What happened to your transmission to have to have it replaced?
 

·
Registered
Joined
·
135 Posts
I would like to know what happened too. Did it quit working all at once? Was it making funny noises? Slippage?
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #8 ·
calibered said:
I would like to know what happened too. Did it quit working all at once? Was it making funny noises? Slippage?
Sorry it took me so long to get back to you. I went on an hour long ride and used my cruise control. When I pulled off the exit my check engine light came on. It stayed on for 3 days then went out the morning I took it to be serviced (go figure...just like a sick kid) They updated the computer and sent me on my merry way. But on the way home the RPM's were up to 4,000/5000 and it wouldnt kick back down unless I took my pedal off gas. I said this wasnt right but they kept telling me it was acting fine that it was suppose to do that...its not like other engines. I told them I have been driving this car for 5000 miles, I know my car... and its not fine!!!! I told them I filled the tank up with gas...to drive it and notice the RMS. They still said nothing was wrong. Finally they too took it on the interstate, went to 70 mph and the check engine light came back on. They put it on the computer reader thing and it said transmission problems. I told the dealer...see...I may be a women and I may be blonde BUT I'm NOT STUPID LOL.
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #9 ·
Oh...they are replacing the tranny because Diamer Chrysler wants to diagnose the probem incase it happens to others, being the car is so new...they said they would rather replace the tranny then the dealer try to find out whats wrong with it. I am VERY grateful for this! I just miss my car :(
 

·
Registered
Joined
·
1,337 Posts
wow that sucks! hope you get it back fast. oh and the loaner ---- i hear burnouts and Nutruel drops into drive....woohooo....then take it back and be like......there's something wrong with the transmission. everything i touch the tranny breaks on it.
 

·
Registered
Joined
·
683 Posts
Sometimes when accelerating up mountain grades my engine light will start to blink. It stops when I let off on the pedal or the highway levels off. Engine seems fine as does the transmission so I don't know what the light means. Would there still be a code even though the light goes back off? Is there a way to see the codes similar to older Dodges (ignition key on-off-on-ff-on sequence)?
 

·
Registered
Joined
·
976 Posts
Yes same key sequence brought up something in my Calibers
right hand and middle display,but just showed dashes in right
and flashing thuderbolt in center display.
 

·
Registered
Joined
·
26 Posts
Huff said:
Sometimes when accelerating up mountain grades my engine light will start to blink. It stops when I let off on the pedal or the highway levels off. Engine seems fine as does the transmission so I don't know what the light means. Would there still be a code even though the light goes back off? Is there a way to see the codes similar to older Dodges (ignition key on-off-on-ff-on sequence)?
This will be interesting for me. We live in Phoenix and make weekend trips up north to Payson AZ (about 120 miles each way) with a couple of heavy inclines on the way up. Waiting to get at least 1k on it before taking it on its first trip north.
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #14 ·
UGHHHH! Well dealer called me yesterday and told me that Diamer Chrysler was NOT going to replace my transmission like they said Thursday. They want to do a few electronical diagnostic testing to see if its the harness or electrical first. In the mean time they cant tell me when I will get my car back. They did give me a loaner which I had to take back today because the check engine light came on that one too. They gave me another loaner and this one is much better. I WANT MY CAR BACK...but I want it feeling better too...I'm soooooo frustrated!
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #15 ·
Lightning bolt was on on mine to when the engine light was on...but then they both went out...lightning bolt didnt return...only engine light did....
 

·
Registered
Joined
·
277 Posts
the lightnig bolt has to do with the electronic throttle control. Take it in ASAP. You guys should REALLY read the owners manual!!!!
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #17 ·
black-sxt-sport said:
the lightnig bolt has to do with the electronic throttle control. Take it in ASAP. You guys should REALLY read the owners manual!!!!
UMMMMM...hello....I DID TAKE IT IN!!! They have had it for a week now...my car is being used as a guinnea pig with all kinds of testing going on. I read the manual....and now I'm frustrated :)
 

·
Registered
Joined
·
135 Posts
Sounds like it could be something as simple as a computer glitch. Hopefully that is the case. Unfortunately, it can be time consuming when trying to diagnose computer and electrical issues. It would be quicker to install a new tranny, but if the problem is an electrical/computer issue, you are still going to have a problem. If you are turning that kind of RPM and are not moving very fast, you could run into a potential overheating situation. Please let us know what the final outcome is.
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #19 ·
OK Peoples.....I got my baby back today. I'm so glad shes feeling better...Like I'm driving a new car again :)
This was the diagnosis: (off work order) Secondary pressure solenoid active, stuck off...incorrect gear ration stored...Internal Malfuntion in module... Tested and replaced transmission control module.
Must have been it because shes working beautifully and RPM are only 1500 - 2000 where they should be!
 

·
Registered
Joined
·
135 Posts
Thats great to hear. Problems with a new vehicle are always frustrating. At least it was a problem with the transmission control module and not the transmission itself.
 
1 - 20 of 20 Posts
Top