Dodge Caliber Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
Well I picked up my Cali about 3 months ago and just found this forum and have learned alot but now I have some questions.

1. Uconnect, does anyone have pictures of a stock install of it since mine didn't come with it I want to install one that looks stock.

2. Has anyone had a condensation problem on the windshield? Above the left defroster I seem to gather condensation on the windshield and I have no idea why

3. Cold morning starts. This is what made me find the board was I have had 2 mornings where it was 30F or less and the cali didn't want to start. A little gas and alot of starter use got it running but I don't want to cause any problems down the road

Thanks for any input that anybody might have
 

·
Registered
Joined
·
413 Posts
the condensation is due to the a/c compressor is running whether or not that you have the a/c button on or off when your selector is on the defrost position. turn your selector to vent until you need to clear any fog off your windsheild, then switch it back.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #3 ·
After I posted I noticed I did'nt give the correct information about the condensation. I parked the car to go watch a movie and when I came out I had alot of water on the inside of the windshield. I don't recall the setting of the controls but it wasn't there when I went in.
 

·
Registered
Joined
·
1,985 Posts


Not much to see in a factory uconnect install... just the mirror.
 

Attachments

·
Registered
Joined
·
1,707 Posts
NJGuy said:
After I posted I noticed I did'nt give the correct information about the condensation. I parked the car to go watch a movie and when I came out I had alot of water on the inside of the windshield. I don't recall the setting of the controls but it wasn't there when I went in.
Did you have the re-circulate buttom pressed? If so, then humidity builds up in the vents and when you shut off the car, it will condensate on the colder windsheild. As sugested, try running it on vent for a few seconds before shutting off the car.
 

·
Registered
Joined
·
1,985 Posts
That is the sun visor latch mount point. I still had it out in that pic after installing the uconnect mirror.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #8 ·
Thanks for the info I don't recall if the recirc was on or not.

Also thanks for the pic because every search I found for uconnect shows an insert type of device and not the mirror so I guess its call the dealer tomorrow to see if I can get one.
 

·
Registered
Joined
·
143 Posts
can't speak of your cold start problems.. my caliber starts after about 3 cranks in -30c weather. If your having problems you should plug in your block heater.. who knows, maybe they put something a lil special in our canadian calibers lol.
 
1 - 9 of 9 Posts
Top