Dodge Caliber Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey hey.
Ive had my 2010 dodge caliber (2.4L) for going on 2 years.
I LOVE my car, "gilbert" :LOL: but I'm close to putting a dang brick on the gas pedal and seeing how big of a boom it will make when it hits bottom!
I know very little about cars.... combine that with the lack of money trees blooming and an ex so dang stupid, (he put the spark plugs in crooked in his truck and couldn't figure out why his truck wouldn't run. Sadly that was not the dumbest thing he did).
So here is Gilbert's issues....
After I drive my car for a good 15-20 mins at highway speeds of 60ish, it begins by surging forward a handful of times. I do not lose speed or anything when it surges or lunges forward. After a few minutes it will then start making this humming/whining noise and my rpms will go up a little. Few mins later the temp light kicks on. The noise slowly gets louder. If I am not able to pull over or stop, 5-15 mins later the engine light will come on. ....The next part does not happen every time in this sequence.... At times, if I'm still driving it and it is hot outside, my car will drop down to about 40-45 and it won't let me speed up.
Ive had the codes read and from that I changed out both o2 sensors. That did not fix the issue. They were nasty, so they needed replaced anyhow I guess. But after they were replaced, my car drove better for a good 15ish mins on the highway. Then it started doing all of that again.
I am giving it a tune up in a couple days. Spark plugs, filters, fluids and anything else it may need. HOPEFULLY that fixes the issue. After searching the internet, I assume it could be the catalytic converter. I hope not cause it's expensive!
Anyone have these issues or can shed light on any of this?
Please remember that I don't "speak car". BUT, I'm not stupid either. Tred lightly boys :LOL::D:)
 

·
Registered
Joined
·
2 Posts
Update....
Both o2 sensors, all spark plugs, air filter has been replaced. No change.

o_OHOWEVER, here's the odd thing... I am HOPING this sets off bells for someone....
I drove my car to my parents house the other day, which takes 1 1/2 hours to get there and it was around 72ish outside, with it being dusk. (Sun down) My car drove PERFECT!!! It did not lunge, make the usual weird sounds, no engine or temp light going off, no dropping down to third gear.....
So apparently, it being hot out effects my car so much that it sets all of that off. Surely that has to mean something, right? I could understand if I was just running to the store a few minutes away but for me to drive an hour and a half and it didn't do the normal stuff cause it was cool outside..... hmmm.
Suggestions?

..... as far as the fluid and filters changed, I have not been able to financially do it yet sadly. I have not found a shop to do it, other than a dealership cause it's a sealed unit. So of course, it's going to cost more.

THANK YOU!!!!!!!
 

·
Registered
Joined
·
1 Posts
I have an 07 noisy little price of junk sadly I am on my own and on last payment on a car that leaks makes noises today stalled out battery light on but battery fine gas cap issue took me months to fix in the end an old used cap did the trick steering pump leaks and steering is tough I can't afford to fix nor buy another but i.xan say these cars don't fair well in cold temperatures or hot ones I want a refund my town n country 300k miles few issues ever what happened dodge you really dropped the ball with this car disappointed for good...
 
1 - 4 of 4 Posts
Top