Dodge Caliber Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I'm starting to get scared! I just bought my 07 caliber 4 days ago (used) and I keep finding things wrong with it! While these things are small, i'd still like to get them fixed. Anyways, the problem I have for you all today is that neither the cigarette lighter nor the power outlet (150V right?) are working. Is there like some sort of a trick to getting power to these? Yes I have tried using them when the car is started and have got nothing. Could it possibly be a fuse? Any help/advice is always appreciated.
 

·
Registered
Joined
·
3,005 Posts
Fuse is blown
 

·
Premium Member
Joined
·
29,881 Posts
did you buy this car from a dealer or where?

And do you have warranty coverage?

Try a fuse, I forget which one it is. Maybe something got unplugged too?
 

·
Registered
Joined
·
1,955 Posts
I'm starting to get scared! I just bought my 07 caliber 4 days ago (used) and I keep finding things wrong with it! While these things are small, i'd still like to get them fixed. Anyways, the problem I have for you all today is that neither the cigarette lighter nor the power outlet (150V right?) are working. Is there like some sort of a trick to getting power to these? Yes I have tried using them when the car is started and have got nothing. Could it possibly be a fuse? Any help/advice is always appreciated.
You mean Watts not volts lol.
 

·
Registered
Joined
·
1,955 Posts
check your fuses

When my cig lighter/sunroof/power outlet stop working, there's a 15 fuse that's blown, has gone 3 times already
Id be worried about the cause of this blown fuse. Its blowing for a reason, usually a short somewhere, and id want that at least documented on a work order.
 

·
Registered
Joined
·
1,013 Posts
sorry, forgot to add.... my fuse always (only, but always) blows when I use the tire inflator.... it'll work great for tire #1, then I start to fill tire #2 (after the track) and pow-wow-wowers gone (I carry spare ones now for when Im at the track/need a refil for my tires...)

Although,,... I think each time my car was turned off... maybe if I had it on that problem'd go away?
 

·
Registered
Joined
·
1,955 Posts
sorry, forgot to add.... my fuse always (only, but always) blows when I use the tire inflator.... it'll work great for tire #1, then I start to fill tire #2 (after the track) and pow-wow-wowers gone (I carry spare ones now for when Im at the track/need a refil for my tires...)

Although,,... I think each time my car was turned off... maybe if I had it on that problem'd go away?
Was it on accessory? Ive used the tire inflator plenty of time without the car running and never blew a fuse.
 

·
Registered
Joined
·
1,013 Posts
Yea, it was just on accessory, I havent tried with the car on...

its happened everytime I use it... (other chargers, etc have worked fine... must draw less power or something)
 

·
Registered
Joined
·
1 Posts
I certainly need help here. My cigarette lighter would randomly charge then stopped completely. I've had no problems with the back wiper. I replaced the cigarette lighter with no success. I changed the #16 fuse with no luck as well. The old fuse looked fine.
What else might it be? Any ideas will be appreciated !
 
1 - 11 of 11 Posts
Top