Dodge Caliber Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 · (Edited)
My stereo sometimes doesn't work and it cuts out completely, and in the cluster it says no fuse, i just bought my caliber this month and its only been less then two weeks since i got it and i have found alot of electrical problems with the car like my fog lights be going on an off, or my power mirrors work when they want, or the alarm sometimes doesn't work. Anyone having problems like this when they first got there car................Any input or similar problems please inform and what you did to remedy the problem..........I am going to bring it back to the dealer so they can look at it......................:mad:
 

·
Registered
Joined
·
614 Posts
I haven't heard anyone report that many electrical issues. Some things may be attributed to the cars user settings aka exit lighting and locking processes. If you cannot resolve any of those via the owners manual, see your dealer ASAP.

I agree with the difficulty on the bold type. Regular text is so much less effort to read.:)

Let us know how this resolves.
 

·
Registered
Joined
·
146 Posts
Kinda pushy for a newb.



I'm not sure, but I think some of those questions could be answered via the search function. I think bringing it to your dealer is a good idea, like you said. Sorry I can't be more help. :)
 

·
Registered
Joined
·
146 Posts
TechMan said:
I haven't heard anyone report that many electrical issues. Some things may be attributed to the cars user settings aka exit lighting and locking processes. If you cannot resolve any of those via the owners manual, see your dealer ASAP.

I agree with the difficulty on the bold type. Regular text is so much less effort to read.:)

Let us know how this resolves.
You should have tried reading it when it was BRIGHT blue. :D
 

·
Registered
Joined
·
146 Posts
TechMan said:
I haven't heard anyone report that many electrical issues. Some things may be attributed to the cars user settings aka exit lighting and locking processes. If you cannot resolve any of those via the owners manual, see your dealer ASAP.

I agree with the difficulty on the bold type. Regular text is so much less effort to read.:)

Let us know how this resolves.
You should have tried reading it when it was BRIGHT blue.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #9 ·
Crahel said:
Mine did the same. Mechanic checked the fuses. The fuse was not seated properly.
thats what the problems were from, the fuse was not seated properly. I pushed them into place myself and its been working 110% now. thanks for the input on the situation.......................
 
1 - 11 of 11 Posts
Top