Dodge Caliber Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
1,707 Posts
Discussion Starter · #1 ·
Has anyone else had thier electronic throttle control light come on? Was driving my Caliber yesterday on a long trip(12 hours) About 9 hours into the drive, I was pulling off the freeway to top off with gas before a long climb up the mountain from Sacramento to Lake Tahoe. Coasting down the off ramp just fine, come to a stop because the light was red. As soon as I stop, I hear the ding and look down to see a flashing lighting bolt light on the dash. I was thinking charging system problem at first. Light goes green, I hit the gas, and the car just starts jerking and barely going. Keep the pedal pushed down and I'm able to get moving and heading down the street, but the car is still bucking. Another light before I can turn into a gas station. I shut the car off and start it again. Light still flashing on the dash. Barely make it into the gas station it's bucking so badly. Pull into a parking spot, shut off the car and pop the hood. Look up the light in the owners manual and it's for the electronic throttle control. Manual says if light is flashing could cause loss of power and erratic throttle movement(NO SHYT!!!) Everything looks good under the hood, connectors on the throttle body are tight. Get back in, start it up, and light stays off. Drive over to the gas pump, and it drives fine. Fill up and complete the trip without another problem.
 

·
Registered
Joined
·
267 Posts
The "con" of having a vehicle more and more computer-controlled. Anyone who has ever owned a PC knows that they crash for no apparent reason sometimes and have to be rebooted (and yes I know it happens to Macs too, perhaps less but it still does). The Caliber seems to need a reboot every now and then... that's not encouraging.
 

·
Registered
Joined
·
101 Posts
i had a problem similar to this a while ago with my ABS lamp... turned the car off... and back on... and it was gone...
 

·
Registered
Joined
·
203 Posts
This just sucks.... he called me from the gas station.. I thought he got in a wreck.. but tells me what happened.... MAN this is a spanking new car, and we have had NO problems with it until now.. I hope this isnt a trend to come.
 

·
Registered
Joined
·
101 Posts
Brooksie1of1 said:
i had a problem similar to this a while ago with my ABS lamp... turned the car off... and back on... and it was gone...
And I had the same thing with the battery light. Guess it's one of those bugs you gotta expect when you buy the first model year of a car.
 

·
Registered
Joined
·
77 Posts
When it comes to symptoms like you described I normally do the following:

1. Freak out and yell at the top of my lungs "serenity now!"

2. Check all connections under the hood and under the dash. Never know, it could be a loose connection, even if it hasn't happened since.

Mind you it could be a PC problem as well. Go to the dealer and get it hooked up and get a complete readout done. the problem will be in the bloody box and the mechs should be able to go from there.

My $0.02 CDN worth.

Regards
 

·
Registered
Joined
·
83 Posts
i just restarted the car while on the 3rd lane on the speed-way (i can not recommand that children to do that at home :)) , did not reoccurr... i guess it was just one of those cosmic particles passing by, hitting some circuit.

when i stopped i looked into the manual which states, that i should get to the dealer to check the car.
i guess i will do that the next time i see the light going on.
 

·
Registered
Joined
·
24 Posts
I had that exact problem happen to me only once around 4-500 miles... light turned on, it still drove alright though, i pulled over shut off the car, started up again and guess what....no more light??? i called the dealer about it and what was weird is when they looked at it, the light had no record of ever coming on.
 

·
Registered
Joined
·
1,707 Posts
Discussion Starter · #10 ·
Well, had mine looked at. They said there was a stored code, but it was for high intake vacume, and nothing to do with the throttle control. The cleared the stored code, drove it for 10 miles and of course couldn't find anything wrong.
 

·
Premium Member
Joined
·
29,881 Posts
speaking of having to reset computers in cars....
one of the many problems our 04 caravan has is that it doesnt like my cd's every now and then, whe i first start the thing the cd player just keeps spinning the disc and nothing happens, so the only way i have figured out of fixing it is to retsrt the van, which has worked on a highway off ramp:eek: , in traffic:eek: and while stopped. Btw all three times the van was stopped when i turned the van off and restarted it. (it has been in for the check engine light about 6-7 times since we got it 2 year ago, plus more for other warranty issues)

Oh... and sorry for hijacking the thread ...lol:rolleyes:

Lets hope the caliber wont be plagued by this sort of thing, i really wanna get one...
 

·
Registered
Joined
·
3 Posts
I also had the ETC light on my car come on while going 70 mph and the car just shut down. After manuvering to the right shoulder and coming to a stop I was able to start the engine again. I took it to the dealer and they took it for a drive and it was fine. So they gave it back to me, again they said there was nothing they could do.
 
1 - 12 of 12 Posts
Top