Dodge Caliber Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Well, talked with the engineers today. They got my new cam sensor in and put it on. It took care of the engine light and the problem with it dying while idling. It didn't fix the cruise though. The engineers tell me that this has become a widespread problem for the calibers made in the time frame that mine was. They say that there are several, maybe hundreds, that are affected. (Wouldn't they do a recall?) And that mine will be the guinea pig. They have three engineers working on the problem now...thought they had it solved with the cam sensor. They say I could have it back today, don't know. Now, they feel like it's some sort of wiring shortage somewhere, just can't locate it. Time will tell.
Good day all!
 

·
Registered
Joined
·
361 Posts
amyjw said:
The engineers tell me that this has become a widespread problem for the calibers made in the time frame that mine was.
When was your Caliber built?
 

·
Registered
Joined
·
683 Posts
They should hook up their co-pilot computer and go for a drive. When the cruise shuts off their co-pilot computer will register exactly what the Calibers computer saw that caused it to shut cruise off. That becomes the area to focus on in finding the problem.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
Okay, they figured out what was causing the rest of the stuff. As I said, they replaced the cam sensor and the cruise still wasn't working right. So, they found that a heat shield had been improperly installed...it was about 1/4" off from where it should have been and it was crimping a pink & yellow wire.

Sorry, I'm not real sure when mine was built. I guess I find that on the door panel sticker?

Hope this info helps...he said that they now know what to look for and do with the rest that have come in. Now that they know, you can be in and out if this happens with yours.

:)
 

·
Registered
Joined
·
614 Posts
My speed control stopped working as well and was fixed by a new on/off micro switch in the steering wheel lever control. Fine now.
 
1 - 6 of 6 Posts
Top