Dodge Caliber Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
585 Posts
Discussion Starter #1
OKSO,

I purchased an 08 CSRT4 a week ago from the dealer lot and everything was fine. Last night, I took a drive to my parents house to remove the audio equipment I had installed in my other car, which they bought. I headed home and everything seemed fine.

This morning, I get up and go to work. I pulled out to the main road realized that I needed to get up to speed quickly due to a car changing lanes and the CSRT just would not go like it did the night before. I checked my boost and I'm only pushing 8 PSI. I thought maybe it was due to the car not being fully warmed up, but after it warmed up, it still only spools to 8 PSI.

What gives? Side note, I'm new to the turbo market as all my previous cars were NA.

Do the CRST's prevent full boost when not fully warmed up, and if so, why did it not give me the full factory 12 PSI after it was at NOT.

Any help is greatly appreciated.

-Steven
 

·
Registered
Joined
·
7,103 Posts
my does the same thing if its cold, i guess to prevent engine damage.
 

·
Registered
Joined
·
2,186 Posts
You have to be over 80*C before you'll get full boost, but for stock PCM it isn't unusual to see only 8PSI if it's cold out because you're making more power in cold air so less boost is needed to reach the desired power output.
 

·
Registered
Joined
·
7,103 Posts
what dont you know:jester:
 

·
Registered
Joined
·
585 Posts
Discussion Starter #5
You have to be over 80*C before you'll get full boost, but for stock PCM it isn't unusual to see only 8PSI if it's cold out because you're making more power in cold air so less boost is needed to reach the desired power output.
That makes perfect sense. I will wait until its warmer outside and test again.

Thanks for the help guys.

-Steven
 

·
Registered
Joined
·
299 Posts
there should be a big sticky about issues like this and other things like the temp gauge for newbies because every week we seem to get these easy answers.
 

·
Registered
Joined
·
585 Posts
Discussion Starter #7
there should be a big sticky about issues like this and other things like the temp gauge for newbies because every week we seem to get these easy answers.
My apologies, I must not have searched for the correct thing. Perhaps the sticky is in the problems category...

Thanks for the help though.

-Steven
 

·
Registered
Joined
·
299 Posts
My apologies, I must not have searched for the correct thing. Perhaps the sticky is in the problems category...

Thanks for the help though.

-Steven
hey theres no need for apologies here, and there is no sticky. i did go ahead and make a thread and hope it does get stickied but who who knows. no worries man i often ask really simple questions here and everyone here is pretty good at helping each other out.
 

·
Registered
Joined
·
445 Posts
cold engine will bleed off boost via the pcm control , I've seen it as low as 5 psi when cold. As far as 12 psi, I rarely seen that in the past year that I owned the car, it was usually between 9-11 psi max , with the majority of the time being closer to 9.
 
1 - 10 of 10 Posts
Top